IonCube Loader is an instrument, that's needed to run files that are encrypted with ionCube PHP Encoder. The latter is an app employed to make PHP code human unreadable, so as to protect it from reverse engineering or unauthorized use. Many script-driven applications, particularly forums, content management systems and e-commerce solutions are encrypted with ionCube PHP Encoder, therefore when you buy a script and you notice that ionCube is one of the hosting environment requirements, you have to make sure that your web hosting server has the instrument pre-installed. While it's not that difficult to install it when you have your own server, it's almost impossible to do that on a shared hosting server since the PHP environment should be precompiled and all of the clients on the server will be affected.

IonCube in Cloud Hosting

IonCube Loader is supplied with each and every cloud hosting that we offer and you're able to activate it anytime with only a couple of clicks, so you will be able to use script apps which require it. You can do that through the PHP Configuration section of the Hepsia Control Panel and all it'll take to enable or deactivate ionCube is to click a single button. The change takes effect within a minute, which means that you will be able to proceed and set up the application that you need right away. The very same section will allow you to switch the PHP version which is active for your account, as we support multiple releases on our advanced cloud platform. If you move to a release that you haven't used to date, you will need to activate ionCube Loader once again. Experienced users can use a php.ini file in a specific domain folder in order to set a PHP version different from the one for the entire account or enable/disable ionCube Loader.

IonCube in Semi-dedicated Servers

If you obtain a semi-dedicated server plan from us, you can employ any script-driven application that requires ionCube Loader as the software tool comes with all servers which are a part of our modern cloud web hosting platform. We also support various releases of PHP, so if you switch from PHP 4 to 5.2 or 5.3, for example, you can activate ionCube for this particular version with just a click from your Hepsia Control Panel. Our system will remember your choice, and if you switch back to the earlier version of PHP, the instrument will already be active. For more experienced users, we also offer the option to choose the PHP version and if ionCube will be active or not for a specific domain without altering the settings for the entire website hosting account. This can be done by putting a php.ini file inside a domain folder with several lines of code.